This project is read-only.

Debug missing messages collection loading

May 29, 2008 at 11:42 AM
Edited May 29, 2008 at 2:44 PM
Have anyone knows how to debug the first time messages collection get populated ?

I've got breakpoint everywhere when execute this line IMAPFolder folder = client.Folders["INBOX"] none of those get hit.

Alberto Acosta.
May 29, 2008 at 2:10 PM
When using that method to select a folder, the folders message objects are populated in IMAPFolderCollection.cs. At this point the folder is examined, and a list of all the msg UIDs is pulled from the server. a new IMAPMessage object is created and the UID is assigned for each message.
May 29, 2008 at 2:48 PM


JasonMiesionczek wrote:
When using that method to select a folder, the folders message objects are populated in IMAPFolderCollection.cs. At this point the folder is examined, and a list of all the msg UIDs is pulled from the server. a new IMAPMessage object is created and the UID is assigned for each message.


That is my point, when i use a break point in InterIMAP.GetMessageIDs VS2008 is not breaking at all, I know this line gets invoke because if I change the string in c.Log(IMAPBase.LogTypeEnum.INFO, String.Format("Added message UID {0} to folder {1}", id, this.FolderPath)); i can later see the change on console but still the break point won't work

Have you try that ?

May 29, 2008 at 5:59 PM
it breaks fine for me when i put a breakpoint on the log line. Can you post what code you are using? and configuration settings? Is there a specific problem you are seeing that you are trying to figure out?
Jun 2, 2008 at 11:18 AM


JasonMiesionczek wrote:
it breaks fine for me when i put a breakpoint on the log line. Can you post what code you are using? and configuration settings? Is there a specific problem you are seeing that you are trying to figure out?


For some reason vs2008 was not hitting the breakpoint for this project but i fix it as soon as I change the project location.